
Copycode 3.3
VB source code copy utility for VB 3.0

One problem of VB is that you can only open one project at a time. If (like me) you have a lot 
of projects with great functions that you would like to use in a new project, there is always the 
possibility of adding the source file that contains the source you need. That would, however, 
leave you with a lot of unneeded functions. And this works only if you don't already have a 
duplicate procedure name in the project.

Well, ok, you could try Notepad, or MS-Write, but that would leave you with a lot of 
unstructured and unneeded code (your forms descriptions). Notepad can also only edit 32Kb, 
not enough for the more complicated forms files.

Copycode comes to your rescue. It allows you to open a second project next to your VB 
environment. And it can show you which of the procedures in your project are not needed 
anyway.

Installing Copycode

In order to use Copycode you do need to have:
VBRUN300.DLL (not included, as it belongs to VB 3.0)
CMDIALOG.VBX (not included)
COMMDLG.DLL (not included)

in your \windows\system directory or in the directory that contains Copycode.exe.
Copycode creates a .INI file in your \windows directory (it contains the 4 most recent files you 
edited in Copycode and registration information when registered).

For version 3.2 I removed MDIChild.VBX. I used it as it came with VB 2.0, but of course VB 
3.0 has better ways to handle MDI-forms. So this saves a few resources. I wouldn't mind if 
you removed MDIChild.VBX from your system, but first make sure you dont't need it 
elsewhere.
Funny though, I didn't use this VBX at all anymore since release 2.0. 

Running Copycode

Opening files
After choosing the File-Open command (either from the menu or by clicking the FileOpen 
icon) the Windows common open file dialog appears. Standard file-extensions are *.MAK, 
*.BAS and *.FRM. By choosing a *.MAK file you open all relevant *.BAS and *.FRM files.
You can also open *.FRX files. In this case Coycode reads the information from the FRX file.

You can also open a file from the recent-files menu within the File-menu. Copycode 
remembers the last 4 projects/files you opened. These files are read from the Copycode.ini 
file (in your Windows subdirectory).

After opening all relevant files, the source code of the first procedure is shown in its window  
(new in release 3.1).

BTW: for Copycode to work properly, you have to save all VB source files as Ascii files. Only 
then will Copycode read the file. You can save these files from the VB File - Save As menu, 
by checking the Save As Text checkbox. Once a file is saved as an Ascii file, you do not have 
to worry about it anymore.
Also choose Save as Text as the default option for VB. You may find this option under Options
- Environment - Default Save As Format - choose Text instead of Binary. After that all new files
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are saved as Ascii as standard.

Resizing Windows

Use the maximize and minimize buttons in every window to make more or less room available
for editing. After resizing the main window the child windows are not automatically resized 
(unless a child window is maximized whithin the main window). The reason being that after 
resizing the main window all child windows would appear cascaded, which is not pleasing to 
the eye or usefull.

Editing Visual Basic source code files

Cut, Copy and Past

Just like all Windows programs Cut, Copy and Paste can be chosen from the Edit menu or by 
clicking one of the icons in the buttonbar (only when a file is available).
There is no Save-file option, so you can only use Paste and Copy for reorganising your files 
prior to copying a large amount of code.
Once in a sourcecode window, you can reach a quick-menu by pressing the righthand mouse 
button, which allows for cut, copy, paste and Select all Text actions. Choose Select all text 
and then Copy to copy all of the procedure.

Finding text

There is a Find text option (within the Edit menu). After pressing the Find-button in the Find-
window, Copycode will show a listbox with all the procedures that contain the text you're 
looking for. Double-clicking on one of these routines lets you see the procedure. The text you 
searched for is highlighted. You can of course select all text and copy and paste the text, 
these functions are available form the menu. By keeping open the listbox containing the 
referenced text after double_clicking a line, you can access multiple instances of the text.

Fonts and Colors

VB doesn't offer it, Copycode does: the option to change the font and color in a child window. 
By choosing a small font, you can view more code on a line.
Choose Font or Color from the Options menu and play for a while.
Check All Windows from this menu prior to choosing a font or color to change alle windows in 
one go (new in 3.1).
Sorry Copycode can't show reserved words highlighted like VB, but where are we without 
anything to wish for.

Copying Graphics files data

When all VB-forms are saved as Ascii, VB creates FRX files, that contain the graphics 
information from the forms. This includes the Forms-Icon and all icons and bitmaps in 
Picturebox controls and Image controls. By using the Spy:FRX technique it is possible to read
these graphics.
After opening an FRX file, Copycode reads the file and displays the information in the two 
listboxes in the main window. The left hand listbox shows all BMP's and WMF's. The right 
hand listbox shows all Icons within the FRX file. The names shown are fictional.
By choosing one of these graphics names, the relevant graphic is shown.
At this time you van choose to:
-copy a BMP or WMF to clipboard (by pressing the Copy-button or Menu Edit-Copy)
-save a BMP (choose from the File menu the Save Bitmap option)
-save an icon (choose from the File menu the Save Icon option)

Optimizing your source code
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The advantage of reusing sourcecode from existing projects (by using existing forms or 
modules) is that you do not need to do a lot of extra work. The disadvantage is that you could 
end up with a lot of code you actually do not need. So, CodeAdvisor was built for you.
What it does?
Not very much. It just reads your code and checks for procedures, constants and declarations
which are never actually called in your code. When it finds these, CodeAdvisor creates a 
report on screen, mentioning all these procedures, constants and declarations. CodeAdvisor 
never touches your code!
You can save the report (as an Ascii-file) by pressing Menu File-Save CodeAdvisor Info.
CodeAdvisor doesn't look for procedures with an Underscore character (it might be an custom
event not known by Copycode or myself for that matter).
If CodeAdvisor finds an obsolete procedure and you decide to delete it, I advise you to rerun 
CodeAdvisor: there could be constants or calls to procedures that are no longer present in 
your project after deleting the procedure.

Before actually deleting anything, be sure to make a back-up of your project. I tested this 
function, but I will not accept any claims for lost code...

You can find this CodeAdvisor option after loading a Project. It is situated in the Edit menu. I 
even created a nice button for it, it is the one with the two ovals and a small arrow pointing 
from the large oval to the small one.

Create a personal VB library
After using Copycode for some time, I found that I needed to load several projects that 
contain usefull procedures. So I decided to add the Make-Lib option. You can use it in this 
manner:
Hilight a procedurename in the right-hand listbox (the regular, not control-bound one).
Press the right hand mouse button and choose the To-Library option.
That's all folks.
To save your library, choose the Save library option beyond the File menu.
To reload the library: Open Library.
Note: This is the first release. After loading a library: DO NOT choose CodeAdvisor, that 
would result in loads of unneeded code (depending on your library size).

Project Information

Copycode shows:
Project information: shows statistical information about your project. The indicated number of 
Constants and delarations shows a question mark unless you run CodeAdvisor.
The Make-file: You guessed it
About...: Copyright information and registration details.

These data are available form the File-menu

Any comments?

Please E-mail in, I like your responses and try to cope with them.

Revision history

Version 1.0. There is also a version in the Dutch language.
Version 1.1: Loads all files
Version 1.2: Includes a Recent-files option. 
Version 2.0: Bye bye 32 Kb-limit (I killed the dutch language version too, to much effort)
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Version 2.1: Removed two 'bugs':

- inability to read single *.BAS and *.FRM files (error 64, invalid path).
- Copycode now shows source code of the upper file in the listboxes after 
  loading a project.
Added:
Copycode now shows the number of subs and functions in the Project info 
window.

Version 2.2: Removed two more 'bugs'
- inability to read files with a path different from the default path of the 
  project (would result in an Error 64 message). It it the same error as the one 
  mentioned above, but I forgot to look at it, as I seldom create projects with 
  shared modules.
- Copycode didn't recognise the Gotfocus-event. It would find the Getfocus 
  event, but that would never occur as this event doesn't exist. 
Added: _Sel* event.

Version 3.0:      Spy:Frx (ability to copy graphics from FRX-files).
CodeAdvisor.
Project Info shows number of declarations and constants (after running 
CodeAdvisor).
Recent files accessible via quick-keys (underscored numbers).
Registration bits.

Version 3.1: Added project helpfile info in Project information window.
Now shows the first procedure after loading.
Change Font and Filesize globally.
Copycode Error 62: Now mentions that you should save as Ascii
Removed a bug: Global-modules larger than 30K would not load, now
CopyCode splits these files. At this moment loading 51K is possible.

Version 3.2: Removed MDIChild.VBX.
Removed the showing of empty declarations section of forms.
Removed a bug: CodeAdvisor would advise to remove procedures of which
the name ended with a Type declaration character while this character is
not used in the calling of these procedures.

Version 3.2: Added Make-Lib option.
An unknown bug in the registration form seems to be resolved unknowingly.

Copycode has a limit of 32 Kb per procedure (due to the limit for VB Text-boxes) and a limit
of 51 Kb for the global declarations area (due to a built in limit).

Copycode So far:
Over 2000 downloads from Compuserve!
Included on (at least) 3 CD-Roms.

Planned for the current version:
-On-line Help (I use the Help Magician from Software Interphase, great tool!)

Possibilities for a future version:
-Printing sourcecode (but why on earth would you want to?)

Technical issues:

I received a few reactions (thanx) after submitting version 1.x. Everyone seemed pleased and 
agreed that the 32K problem would have to be addressed somehow, but nobody could offer a 
solution.
I found one. I decided to try to understand the User Defined Type. Every procedure is stored 
in a UDT and I use a dynamic array to store the UDT's. VB knows how to handle UDT-arrays 
and dynamically creates Huge arrays, even Huge arrays of UDTs.
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The UDT and array looks like this:

Type codetype
    name As String 'procedure name, max 64 Kb
    text As String 'procedure text, max 64 Kb
End Type

Global copycode() As codetype

called:
copycode(n).name="procname"
copycode(n).text=sourcecode ie. "Sub...  ...End Sub"

where n is a unique identifier.

Thanks to:
Several Code Copyiers deserve thanks for their support and ideas. So, thanks to:

Bradley O'Keefe
Guy Verville
Chris Velazquez
Larry Rebich

Also, of course, thanks to MicroSoft for creating Visual Basic and not including Copycode!

DISCLAIMER AND AGREEMENT

Users of Copycode must accept this disclaimer of warranty. If you do not accept this 
disclaimer, do not use the program.

COPYCODE IS SUPPLIED AS IS. THE AUTHOR DISCLAIMS ALL WARRANTIES, 
EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE WARRANTIES OF 
MERCHANTABILITY AND OF FITNESS FOR ANY PURPOSE. THE AUTHOR ASSUMES NO
LIABILITY FOR DAMAGES, DIRECT OR CONSEQUENTIAL, WHICH MAY RESULT FROM 
THE USE OF COPYCODE, EVEN IF THE AUTHOR HAS BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES.

THE LICENCE AGREEMENT AND WARRANTY SHALL BE CONSTRUED, INTERPRETED 
AND GOVERNED BY THE LAWS OF THE NETHERLANDS. YOU MAY HAVE OTHER 
RIGHTS WHICH VARY FROM ONE STATE TO ANOTHER.

Copycode is shareware, and is provided at no charge to users for evaluation. Feel free to 
share it with your friends and colleagues, but please do not give it away altered or as part of 
another system. The essence of shareware software is to provide computer users with quality 
software without high prices, and at the same time to provide incentive for programmers to 
continue to develop new products.

If you find Copycode useful, and you are continuing to use it after the trial period of 90 days, 
you must make a registration payment as indicated in the How to Register section of this 
document. In return you will be given a user name, serial number and access code to disable 
the shareware reminder. This information will be good for all future shareware releases of 
Copycode. You will be informed when such releases become available.

Any person or organisation wanting to distribute COPYCODE for profit must first contact the 
author by post or email for authorisation.

Copyright for this software remains the property of:
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André Koot
Jan Nieuwenhuyzenstraat 54
4818 RK  Breda
The Netherlands

Compuserve address 100120,2360

HOW TO REGISTER COPYCODE

To register a copy of Copycode send your name and address plus either a Cheque on an 
Dutch or English bank, Postgiro, Postal Order or International Money Order for the required 
sum, made payable to A. Koot, to the above address.

Pricing for Copycode is:

25 dutch guilders
10 english pounds
15 american dollars

You may register Copycode through Compuserve in the SWREG forum: type Go SWREG and
register ID 3357.
After registration is confirmed, you will be sent a serial number for Copycode and an access 
code via E-Mail. Enter these with your name in the registration form that is available from the 
About box in Copycode. These data will be written to the Copycode.ini file in your windows 
directory.
Please allow for 2 weeks delivery of the codes after registering. 

I am looking at an other solution for British Code Copiers.

That's all for now,

Greetings form The Netherlands,

André Koot
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